If you are trying to get a device working with ndiswrapper, please help ndiswrapper project wiki by contributing your findings. See HowToContribute

D-Link DWL-G650 Rev B1

From NDISWrapper
Jump to: navigation, search

D-Link DWL-G650+ Rev B1, 54mbps


SUSE 9.2 Ndiswrapper 0.10-3. Works fine also with 128 bit WEP. Installed Ndiswrapper that ships with SUSE 9.2. Add Dlink

  • Driver with "ndiswrapper -i GPLUS.inf" Add "alias wlan0 ndiswrapper" to /etc/modprobe.conf.local. Load driver for the first time with "modprobe ndiswrapper" Plug in the card. Configure it with YAST. Be sure that in YAST networkcard setup at Advanced->Hardware Details the module is set to ndiswrapper. Since SUSE 9.2 ships with native linux acx-111 driver you might get the wrong driver loaded. The linux acx-111 driver lacks support for WEP. Have to replug the card after a suspend to disk. Thanks for ndiswrapper.

Also works with SUSE 9.3. See the readme file /usr/share/doc/packages/ndiswrapper/README.SUSE. No more replug after suspend to disk required. Also got WPA working. Only problem was that there is a typo in the script /etc/sysconfig/network/scripts/ifup-wireless-wpa ! Correct the typo in line 188 "WPA_DRIVER=ndiswrapper" !

Troubleshooting: I used the new driver version 3.10 from www.dlink.de. After 'unshield data1.cab' and 'ndiswrapper -i GPLUS.inf' I had an invalid driver message on 'ndiswrapper -l'. But then I 'cp GPLUS.sys GPLUS_XP.sys /etc/ndiswrapper/gplus', it works fine.